Ticket #26 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

Crash when method returns multiple values

Reported by: qwandor@… Owned by: nobody
Priority: normal Milestone:
Component: library Version: 0.2.1
Keywords: Cc:

Description

When implementing a dbus method that returns multiple values (e.g. with a type like "out a:s, out b:o"), ruby-dbus seems to instead return multiple copies of the first value returned.

The attached patch fixes this.

Attachments

return_value.patch Download (303 bytes) - added by qwandor@… 10 years ago.
Fix for returning multiple values

Change History

Changed 10 years ago by qwandor@…

Fix for returning multiple values

Changed 10 years ago by losing weight Cialis

Changed 10 years ago by anonymous

 Designer Perfume, Ladies' Perfume, Men's Perfume, Bottle Perfume Designer Perfume, Ladies' Perfume, Men's Perfume, Bottle Perfume  Attache Case, Briefcase, Computer Bag, Document Bag, Laptop BackpackAttache Case, Briefcase, Computer Bag, Document Bag, Laptop Backpack  Beer Beer  Cosmetics Set Cosmetics Products Color Cosmetics Cosmetics Set Cosmetics Products Color Cosmetics  Bracelets Fashion Bracelets Fashion Jewelry Bangles Jewelry Bracelets Fashion Bracelets Fashion Jewelry Bangles Jewelry  Portable Steam Sauna Portable Sauna Steam Sauna Sauna Infrared Portable Steam Sauna Portable Sauna Steam Sauna Sauna Infrared  Solar Wind Generator Solar Wind Generator  Solar Panels Solar Panels  Solar Water Heater Vacuum Tubes Solar Water Heater Solar Water Heater Vacuum Tubes Solar Water Heater  solar post lampsolar post lamp  Entry Doors Exterior Doors French Doors Front Doors Garage Doors Entry Doors Exterior Doors French Doors Front Doors Garage Doors  Clothing Maternity Fashion Maternity Jeans Clothing Maternity Fashion Maternity Jeans  Bridal Gowns Bridal Gowns  Seamless Bras Invisible Bra Silicone Bra Women's Bras Lady's BrasSeamless Bras Invisible Bra Silicone Bra Women's Bras Lady's Bras  Bathing Suits Bathing Suits  Babys ClothingBabys Clothing  Chinese Style Cheongsam Silk Cheongsam Chinese Cheongsam Chinese Style Cheongsam Silk Cheongsam Chinese Cheongsam  Yogurt MakerYogurt Maker  Vegetable Washer Fruit Washer Vegetable Cleaner Washers Ozone Vegetable Washer Fruit Washer Vegetable Cleaner Washers Ozone  Sandwich Maker Waffle Maker Sandwich Toaster Kitchen + AppliancesSandwich Maker Waffle Maker Sandwich Toaster Kitchen + Appliances  Ice Cream Machine Ice Cream Maker Soft Ice Cream Maker Ice Cream Machine Ice Cream Maker Soft Ice Cream Maker  Gas Stoves Gas Cookers Stoves Gas Hobs Gas Burner Table Gas Gas Stoves Gas Cookers Stoves Gas Hobs Gas Burner Table Gas  Deep Fryer Fryers Electric Deep Fryers Electric Fryers Deep Fryer Fryers Electric Deep Fryers Electric Fryers  Oven Electric Ovens Toaster Ovens Convection Oven Oven Electric Ovens Toaster Ovens Convection Oven  Disinfection Cabinet Sterilization Cabinet Kitchen + AppliancesDisinfection Cabinet Sterilization Cabinet Kitchen + Appliances  Coffee Makers Coffee Machines Electric Coffee Makers Coffee Makers Coffee Machines Electric Coffee Makers  Bread Maker Electric Bread Maker Bread Machine Automatic Bread Bread Maker Electric Bread Maker Bread Machine Automatic Bread  Popcorn Maker Popcorn Machine Air Popcorn Maker Popcorn PopperPopcorn Maker Popcorn Machine Air Popcorn Maker Popcorn Popper  Microwave Ovens Microwave Ovens  Fruit Juicer Juice Extractor Power Juicer Juice Maker Orange Juicer Fruit Juicer Juice Extractor Power Juicer Juice Maker Orange Juicer  Meat Grinder Electric Meat Grinder Meat Mincer Meat Chopper GrindersMeat Grinder Electric Meat Grinder Meat Mincer Meat Chopper Grinders  Slow Cooker Cooker Kitchen + Appliances Electrical CookerSlow Cooker Cooker Kitchen + Appliances Electrical Cooker  Car Charger Mobile Phone Car Charger USB Car ChargerCar Charger Mobile Phone Car Charger USB Car Charger  Digital Camera Chargers Camera Chargers Batteries Chargers Digital Camera Chargers Camera Chargers Batteries Chargers  Digital Camera Batteries Camera Batteries Recharge Battery Batteries Digital Camera Batteries Camera Batteries Recharge Battery Batteries  Cameras Lens Sigma Lens Optical Lens Lenses Camera Lenses Cameras Lens Sigma Lens Optical Lens Lenses Camera Lenses  Tripod Camera Tripod Professional Tripods Mini Tripod Tripod Camera Tripod Professional Tripods Mini Tripod  Camera Bag Digital Camera Bag Camera Cases Digital Camera Cases Camera Bag Digital Camera Bag Camera Cases Digital Camera Cases  Aluminum Benches Bench Furniture Country Furniture Furniture Benches Aluminum Benches Bench Furniture Country Furniture Furniture Benches  LED Display LED Screen Outdoor LED Displays Full Color LED DisplayLED Display LED Screen Outdoor LED Displays Full Color LED Display  Bus Models Car Models Model Aircraft Plane Model Toy Models Bus Models Car Models Model Aircraft Plane Model Toy Models  Air Inflator Balloons Bounce House Air Inflator Balloons Bounce House  Baby Dolls Doll Beds Doll Clothes Doll Dress Doll Shoes Doll Wig Baby Dolls Doll Beds Doll Clothes Doll Dress Doll Shoes Doll Wig  JewelryJewelry  Contact Lens Contact Lens Case Bluetooth Sunglasses Contact Lens Contact Lens Case Bluetooth Sunglasses  Calendar Clock Digital Clock LCD Clock Pendulum Clock Calendar Clock Digital Clock LCD Clock Pendulum Clock  Games Player Video Game Players Video Game Consoles Game ConsolesGames Player Video Game Players Video Game Consoles Game Consoles  MP4 Player Flash MP4 Players Digital MP4 Player Portable MP4 Player MP4 Player Flash MP4 Players Digital MP4 Player Portable MP4 Player  Memorial Cards SD Card Flash Memory Cards Memory Stick Micro SD Memorial Cards SD Card Flash Memory Cards Memory Stick Micro SD  Digital Cameras Camera Mini Digital Camera Branded Digital Camera Digital Cameras Camera Mini Digital Camera Branded Digital Camera  Bamboo Flooring Cherry Composite Decking Cork Flooring Bamboo Flooring Cherry Composite Decking Cork Flooring  Wall MaterialsWall Materials  Chairs Leisure Chair Furniture Armchair Chairs Leisure Chair Furniture Armchair  Bedroom FurnitureBedroom Furniture

Changed 10 years ago by martin.github@…

  • status changed from new to closed
  • resolution set to duplicate

This is a duplicate of ticket #23, fixed in SVN revision [160].

Note: See TracTickets for help on using tickets.